Installation error

Questions, problems, suggestions, bug reports, and so on.
Post Reply
stony_dreams
Posts: 3
Joined: 2010-05-07 6:57 pm

Installation error

Post by stony_dreams » 2010-05-07 7:08 pm

Hello,

I just downloaded the jscoverage-0.5 and am trying to install it on my linux box. I get this error on the ./configure command:

checking for valid optimization flags... no
configure: error: These compiler flags are invalid: -Os -freorder-blocks -fno-reorder-functions
configure: error: ./configure.gnu failed for js

Any pointers to fix this problem?

Thanks in advance...

Ed
Posts: 120
Joined: 2008-10-11 6:52 pm

Re: Installation error

Post by Ed » 2010-05-07 7:14 pm

What distribution of Linux are you running? And what version of gcc is it using?

stony_dreams
Posts: 3
Joined: 2010-05-07 6:57 pm

Re: Installation error

Post by stony_dreams » 2010-05-07 7:19 pm

Thanks for the quick response. I have the following config (I admit that this is very old):

gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-47)

So is this a version problem? Is there a workaround or some external library that I should install prior to installing jscoverage?

Thanks.

Ed
Posts: 120
Joined: 2008-10-11 6:52 pm

Re: Installation error

Post by Ed » 2010-05-07 7:29 pm

I think you will need at least gcc version 3.4 or more recent in order to compile.

stony_dreams
Posts: 3
Joined: 2010-05-07 6:57 pm

Re: Installation error

Post by stony_dreams » 2010-05-07 8:06 pm

Thanks for the response!

Post Reply