--no-instrument and --report-dir options for the proxy mode

Questions, problems, suggestions, bug reports, and so on.
Post Reply
orgone
Posts: 6
Joined: 2010-03-27 8:27 am

--no-instrument and --report-dir options for the proxy mode

Post by orgone » 2010-03-27 11:19 am

Server is started as proxy:

Code: Select all

jscoverage-server --verbose --ip-address=10.10.10.10 --port 9999 --proxy --no-instrument='http://10.10.10.10:8080/site/js/externals' --report-dir=/root/report
Firefox is configured for using proxy at 10.10.10.10:9999

http://10.10.10.10:8080/jscoverage.html opened

http://10.10.10.10:8080/site is used as URL

JavaScript works -- Summary is updated.

Issue #1: Summary contains js files from http://10.10.10.10:8080/site/js/externals
Issue #2: after storing a report /root/report/jscoverage.html contains no results
(there's a line in server's stdout:

Code: Select all

POST http://10.10.10.10:8080/jscoverage-store HTTP/1.1
)

What have I done wrong?

The same result for the 0.4 version and for a version from CVS.

Ed
Posts: 120
Joined: 2008-10-11 6:52 pm

Re: --no-instrument and --report-dir options for the proxy m

Post by Ed » 2010-03-28 12:13 am

Everything above looks correct ... some things you can try:
  • You mentioned you tried both version 0.4 and the development version; either should work, but make sure you don't mix the two, since the data formats used by the jscoverage-server have changed. E.g., if you run the tests with version 0.4, but then try saving the report with the development version, that will likely cause problems.
  • Do you have caching enabled in Firefox? Try disabling the Firefox cache completely. (That may be why the --no-instrument option seems not to be working.)
  • What web server are you using?

orgone
Posts: 6
Joined: 2010-03-27 8:27 am

Re: --no-instrument and --report-dir options for the proxy m

Post by orgone » 2010-03-31 4:26 am

Ed wrote:Everything above looks correct ... some things you can try:
  • You mentioned you tried both version 0.4 and the development version; either should work, but make sure you don't mix the two, since the data formats used by the jscoverage-server have changed. E.g., if you run the tests with version 0.4, but then try saving the report with the development version, that will likely cause problems.
  • Do you have caching enabled in Firefox? Try disabling the Firefox cache completely. (That may be why the --no-instrument option seems not to be working.)
  • What web server are you using?
Many thanks for your support! The issues are resolved for me now.

The reasons was firefox cache and my patched lighttpd.

Post Reply